[Alug] Installing WordPerfect on Debian

(Ted Harding) Ted.Harding at nessie.mcc.ac.uk
Sat Sep 28 12:40:01 BST 2002


On 28-Sep-02 Ian Douglas wrote:
> On Friday, September 27, 2002 3:43 PM, Ted Harding wrote:
>> [...]
> [...]
> I have now (I think) managed to successfully install WordPerfect.
> [...]
> However if I then try and start WordPerfect it refuses to start
> saying it cannot find "libXt.so.6":
> 
> wilderbeast:/opt/wp80/wpbin# ./xwp
> ./xwp: can't load library 'libXt.so.6'
> 
> Even though if I go into "/usr/X11R6/lib" I can see "libXt.so.6" is
> installed (I am running Debian 3.0) so I am a bit confused.
> 
> Ian.

It looks as though the "lib.so" cache is not complete, and "xwp"
is not finding what it is looking for.

First, try

  strings /etc/ld.so.cache | less

and search for "Xt". In my case, in the midst of all that I can see:

  libXt.so.6
  /usr/X11R6/lib/libXt.so.6
  libXt.so.6
  /usr/X386/lib/libXt.so.6
  libXt.so.6
  /usr/i486-linuxaout/lib/libXt.so.6

i.e. there are three different files for libXT.so.6

You should be able to find out what you have, either by looking
in the several directories as above, or by doing a "locate libXt".

The "lib.so" cache is maintained by the command "ldconfig"
(see "man ldconfig"). You may need to run this by hand, with
appropriate arguments. If that gets it to work, you may need
to modify the boot-time invocation of "ldconfig" (don't know
where to find this on Debian ... ).

The WP executable "xwp" is an ELF binary, so you should not need
"/usr/i486-linuxaout/lib/libXt.so.6" for this purpose.

Hope this is a useful pointer!
Ted.


--------------------------------------------------------------------
E-Mail: (Ted Harding) <Ted.Harding at nessie.mcc.ac.uk>
Fax-to-email: +44 (0)870 167 1972
Date: 28-Sep-02                                       Time: 10:54:30
------------------------------ XFMail ------------------------------




More information about the main mailing list