[ALUG] kubuntu apt-get not installed

(Ted Harding) ted.harding at nessie.mcc.ac.uk
Wed Jun 13 00:54:40 BST 2007


On 12-Jun-07 22:31:22, elc wrote:
> Tried what you suggested Adam, and got 'command not found' for aptitude
> install apt.
> Also had 'command not found' for sudo aptitude install apt.
> In fact I also tried commands ls, man, sudo, and they all returned 
> 'command not found'.
> 
> Does this mean that all (most) of my commands are unavailable?

Looks to me as though your PATH is empty, so your shell has
nowhere to look for the commands.

>From you command line, enter:

  set

and look down the resulting list for a line that starts
with "PATH=...."

If you do not find one, then you have an empty PATH and that
is the problem. On the other hand, if you get a result which
includes things like

  PATH=/usr/local/bin:/bin:/usr/bin:....

then you have real problems. In particular, the command 'ls'
should be in /bin. and therefore found; the command 'man'
should be in /usr/bin and likewise found. So in that case
there is something seriously wrong with your installation.

If you have an empty PATH, this means that some initial
configuration is not taking place when you log in, and we
can probably help you track that down (there are not a lot
of possibilities for what could go wrong there).

But if you get a PATH like the above, it's trouble!

('set', by the way, should work regardless of your PATH
since it is a shell command and not a binary. On the other
hand, if your PATH is empty, then 'echo $PATH' will not
work, since 'echo' is in /bin. Nor will 'env', since it
is also in /bin)).

Hoping this helps. Let us know what you see!

Ted.

--------------------------------------------------------------------
E-Mail: (Ted Harding) <ted.harding at nessie.mcc.ac.uk>
Fax-to-email: +44 (0)870 094 0861
Date: 13-Jun-07                                       Time: 00:54:25
------------------------------ XFMail ------------------------------




More information about the main mailing list