[ALUG] help with wpa_supplicant please

CDW (Linux) cdw_alug at the-walker-household.co.uk
Sun Nov 2 00:41:02 GMT 2008


MJ Ray wrote:
> <keith.jamieson at bt.com> wrote [WITHOUT CREDITING PEOPLE CORRECTLY]:
>> "CDW (Linux)" <cdw_alug at the-walker-household.co.uk> wrote:
>>> If I run wpa_cli, it produces the following :-
>>>> <2>WPA: 4-Way Handshake failed - pre-shared key may be incorrect
>>> <2>CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
>>> <2>Associated with 00:0f:3d:34:d6:f6
>>>
>>> and then repeats the above lines.
>>>
>>> But the passphrase I'm using is the same one I'm using on my wife's
>>> laptop, plus her and my phones. So I know it's good.
> 
> But from the above classic "pre-shared key may be incorrect"
> situation, we know it's not good.  How to resolve this?
> 
> I'd start by checking that it's the latest version of wpa_supplicant
> (I've checked and my wpa_cli really does know the scan_results and
> status commands - wpa_supplicant 0.5.7), that there's no bug reports
> for WPA with that hardware or distribution and that 00:0f:3d:34:d6:f6
> is the right access point.  I can't be the only one to spend 5 minutes
> debugging an accidental connection to someone else's AP!
> 
> Sorry if that's not much help.  I hate networks.
> 
>> Did you say "passphrase" ? This is the term for a "something to make
>> the key". What you need to do it to put in the HEX or ASCII into the
>> key fields. One manufactures "passphrase" makes different HEX to
>> another. You do not have the manufactures software ( on Linux
>> HAHAHAHH! ) then you will not be able to create the HEX needed.
> 
> Huh?  I have a line that says psk="whatevermypasswordis" in my
> /etc/wpa_supplicant.conf, not hex.
> 
> Also, the original poster clearly said this is on DesktopBSD, so
> please stop laughing at Linux like a troll. ;-)

I tired of trying to fix the compile errors on wpa so blew away
DesktopBSD, installed Mandriva 2008.1 (the same as I'm running on this
machine when in Linux mode) and swapped out the network card. It was
previously a Netgear WG511 v2 so thought I'd do the sensible thing and
buy one which was known to work under Linux.

I bought an Edimax card from the Linux Emporium, bunged it in and
after a few attemptes at installing the same key I tried with the
Netgear, it all works.

So thanks for your help.

All I need to do now is fix the screensize which is stuck at 800x600
but I think there's been some discussion on something similar here
recently so I'll be trawling through the archives for a solution to that.

If I was a real glutton for punishment, I guess I could reinstall
DesktopBSD as that sorted out the screensize on its own and see if it
also coped with the new Edimax card but I'm not sure I can be bothered
to go through all that ;-)

Anyway, thanks again for your help. Much appreciated.

-- 
 __ __| |_ __ __  .-----------------------------------------------.
/ _/ _` \ V  V /  |  mailto:cdw_alug at the-walker-household.co.uk   |
\__\__,_|\_/\_/   |_______________________________________________|




More information about the main mailing list