[ALUG] Display error when switching to console from X

Chris G cl at isbd.net
Thu Nov 27 12:00:51 GMT 2008


On Thu, Nov 27, 2008 at 11:21:05AM +0000, Brett Parker wrote:
> On 27 Nov 10:59, Chris G wrote:
> > I'm running xubuntu 8.10 (though I suspect the problem is common to
> > all 8.10 ubuntu versions).
> >  
> > I can run X fairly reliably though I do have some issues when logging
> > in and out presumably due to switching resolutions.
> >  
> > However switching to a console using CTRL/ALT/F1 (or any of the
> > others) doesn't work.  I just get an error message from my monitor
> > saying the resolution is invalid.  My monitor is a Dell 2001FP capable
> > of up to 1600x1200 so I suspect that the CTRL/ALT/F1 is switching to a
> > totally impossible resolution.
> >  
> > How can I fix this problem?  Is there any way to specify the mode and
> > resolution to use for the text mode consoles?
> 
> Please think about what you're posting and provide the neccessary info
> for us mere mortals without telepathic capabilities to help.
> 
OK, sorry!

> So, in this instance:
>     Version of X.Org that you're running

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0

>     Graphics chipset
Intel G45

>     X.Org driver you're using
Well I assume it's Intel. .... yes, here we are:-
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,   
    i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
    E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, G35,
    965Q, 946GZ,
    965GM, 965GME/GLE, G33, Q35, Q33,
    Mobile Intel® GM45 Express Chipset,
    Intel Integrated Graphics Device, G45/G43, Q45/Q43

>     Wether or not you're using DRI
It seems so, from Xorg.0.log:-
(II) Loading extension XFree86-DRI

> 
> And potentially:
>     Kernel version
 2.6.27-7-generic #1 SMP

> 
> I've seen this quite often on nvidia graphics cards using the binary
> nvidia driver.
> 
Well that's not it as I'm using Intel.

-- 
Chris Green




More information about the main mailing list