[ALUG] SSH clients

Mark Rogers mark at more-solutions.co.uk
Tue Jun 13 16:46:44 BST 2017


On 13 June 2017 at 16:37, Chris Green <cl at isbd.net> wrote:
> Have you tried my workaround of modifying /etc/resolvconf/resolv.conf.d/head
> as follows:-

Yes, I tried that after your post on the subject but it didn't work
for me (my problem is similar but subtly different). I did reply to
your post at the time, shout if it never turned up.

> Also, do you have a secondary DNS returned by your DHCP server?  This
> can cause the same problem because 17.04 will change to the secondary
> DNS and *stay* there if there's any sort of hiccough with the first
> DNS.

I've always understood this to be correct behaviour (ie specifying two
DNS servers will pick one and stick with it until it can't reach it,
not try one then try the other if it didn't get a successful lookup
(was was able to talk to the server).

I only have one DNS setting, but yes it is set via DHCP. (At that bit
works: I can resolve anything with a dot in it but nothing without!)
-- 
Mark Rogers // More Solutions Ltd (Peterborough Office) // 0844 251 1450
Registered in England (0456 0902) 21 Drakes Mews, Milton Keynes, MK8 0ER



More information about the main mailing list