[ALUG] SSH clients

Mark Rogers mark at more-solutions.co.uk
Wed Jun 14 16:50:18 BST 2017


On 14 June 2017 at 16:27, Chris Green <cl at isbd.net> wrote:
>
> The basic reason is that 17.04 doesn't use the 'dnsmasq run by Network
> Manager' for local DNS cache, it has a systemd equivalent instead.


Thanks for the detailed explanation.

>     It *should* be able to look up unqualified names but can't for
>     some reason, this is an actual bug and has been reported.


Don't suppose you have a bug reference I can look up?

>     The systemd DNS treats multiple DNS entries in /etc/resolv.conf
>     differently from the previous system.  If the first one fails then
>     it uses the second and *continues* to use the second.  Previously
>     the DNS servers were tried in order.


As I understand it this is "normal" (if frustrating) behaviour and if
dnsmasq did things differently then that might have been nice but not
"normal". (Try putting two DNS entries into a Windows box, for
example.)

>
> For the present I have added a 'search' domain to /etc/resolv.conf
> (well, to the resolvconf configuration actually)


That didn't work when I tried it for some reason but I'll have another go.

-- 
Mark Rogers // More Solutions Ltd (Peterborough Office) // 0844 251 1450
Registered in England (0456 0902) 21 Drakes Mews, Milton Keynes, MK8 0ER



More information about the main mailing list