[ALUG] Strange PC lock-up

Adam Bower adam at thebowery.co.uk
Wed Mar 22 21:31:11 GMT 2017


On Wed, Mar 22, 2017 at 05:47:44PM +0000, Mark Rogers wrote:
> 
> It wasn't launching programs that was the issue though (I do know what
> you mean). The whole GUI had stopped responding (couldn't drag apps
> around etc), and the biggest tell was that the clock had stopped
> updating. The fact that the mouse still moved is what hinted at a
> graphics card issue, as I can imagine that working at a different
> level (that and finding references to nouveau in the logs).

Right, but if your swap partition is on that disk and you can't read/write any
temp files etc. etc. then you get pretty much exactly the symptoms you describe
in that everything appears to have stopped working but you can still move the
mouse. 

Your problem was that you couldn't launch any programs or get back to any of
the ones you were running. That you could connect via ssh but could not login
also very much suggests it could be this as your system is still running just
that it won't let you do anything that might involve reading or writing from
the file system. 

I would suggest that as you know the system is running (evidenced by you can
connect via ssh) and you have good reason to suspect a time the system fails
from the clock that you should use this to see if anything is logged to disk
after the failure time. You may want to set up a periodic task to write various
information to disk and see if that shows anything up. In fact a simple script
writing continually with a sleep every minute with the output of dmesg to a
network mounted filesystem or to a port on another computer which has netcat
running on it may help show up any more detail about the problem.

Adam



More information about the main mailing list