[ALUG] Strange PC lock-up

steve-ALUG at hst.me.uk steve-ALUG at hst.me.uk
Thu Mar 30 21:15:31 BST 2017


On 29/03/17 09:57, Phil Thane wrote:
> I've been lurking and following this because I have had a lock-up too. Not the
> same though so I decided to stick my head up and post...
>
> A few days ago I came to my desktop PC (Linux Mint 18.1, KDE version) and
> found the screen black. Power lights on and case fans running but no response
> to KB or mouse. I hadn't used it for several hours and can't remember what I
> did last but it being bed time I hit the power switch.
>
> Next day it booted OK and various apps left open were restored and worked, but
> KDE kept popping up warnings about being unable to write to config files, I
> should have made a note, but didn't. I assumed it was the incorrect shutdown
> the previous evening had corrupted something, so did an orderly shut down and
> reboot.
>
> Back to Black, nothing on screen at all.
>
> Rebooted with a live distro in USB port and it worked OK, so not hardware
> problem.
>
> Rebooted and this time chose recovery mode. Nothing in the ASH menu seemed
> helpful so finally I ran FSCK and accepted all the suggestions. Success.
>
> But, a few days later, back to black. This time I do know what I did last.
> That morning the desktop seemed sluggish. It hadn't been shutdown for a while,
> I've got in the habit of using Suspend because I use the machine irregularly
> and it's handy having it come to life when I want it. So I set it to reboot
> while I went for lunch. And didn't go back until after dinner, about 8 hours
> later. It should have been sat at the login screen, but clearly wasn't.
>
> This time hit Reset rather than Power. When it came back up I got a simple
> terminal screen telling me the previous desktop session hadn't shutdown
> properly and advising I switch to another terminal and run <loginctl unlock-
> sessions>. That seems to have worked OK.
>
> Does anyone know if this odd behaviour stems from me using Suspend? Haven't
> dared since, it's either on or shutdown now!
>
>
I doubt that it's a suspend problem.  I think that if suspend goes 
wrong, it just won't wake up.  Suspend is usually OK though.

I would guess at a intermittent hardware error or lack of disk space.  
It could be overheating (are the fans working?) or a disk error.  force 
a Fsck it agian, and check the SMART status info.

Disk space?  use df -h to see if there's enough space on each partition.


Is it overheating due to clogging up with dust, or is there a problem 
with the graphics card?

Anyway, good luck!

Steve





More information about the main mailing list