[ALUG] Strange PC lock-up

Phil Thane phil at pthane.co.uk
Fri Mar 31 19:43:29 BST 2017


Thanks for the advice Steve,

FSCK reports no errors.

df -h report:

phil at phil-desktop ~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            4.0G     0  4.0G   0% /dev
tmpfs           807M  9.3M  798M   2% /run
/dev/sda1       909G   85G  778G  10% /
tmpfs           4.0G   92K  4.0G   1% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           4.0G     0  4.0G   0% /sys/fs/cgroup
cgmfs           100K     0  100K   0% /run/cgmanager/fs
tmpfs           807M     0  807M   0% /run/user/121
tmpfs           807M   12K  807M   1% /run/user/1000

So plenty of disk space.

Fans running and not clogged up.

PC runs fine, but I haven't tried Suspend again...


--
Phil Thane

www.pthane.co.uk
phil at pthane.co.uk
01767 449759
07582 750607
Twitter @pthane
On Thursday, 30 March 2017 21:15:31 BST steve-ALUG at hst.me.uk wrote:
> On 29/03/17 09:57, Phil Thane wrote:
> > I've been lurking and following this because I have had a lock-up too. Not
> > the same though so I decided to stick my head up and post...
> > 
> > A few days ago I came to my desktop PC (Linux Mint 18.1, KDE version) and
> > found the screen black. Power lights on and case fans running but no
> > response to KB or mouse. I hadn't used it for several hours and can't
> > remember what I did last but it being bed time I hit the power switch.
> > 
> > Next day it booted OK and various apps left open were restored and worked,
> > but KDE kept popping up warnings about being unable to write to config
> > files, I should have made a note, but didn't. I assumed it was the
> > incorrect shutdown the previous evening had corrupted something, so did
> > an orderly shut down and reboot.
> > 
> > Back to Black, nothing on screen at all.
> > 
> > Rebooted with a live distro in USB port and it worked OK, so not hardware
> > problem.
> > 
> > Rebooted and this time chose recovery mode. Nothing in the ASH menu seemed
> > helpful so finally I ran FSCK and accepted all the suggestions. Success.
> > 
> > But, a few days later, back to black. This time I do know what I did last.
> > That morning the desktop seemed sluggish. It hadn't been shutdown for a
> > while, I've got in the habit of using Suspend because I use the machine
> > irregularly and it's handy having it come to life when I want it. So I
> > set it to reboot while I went for lunch. And didn't go back until after
> > dinner, about 8 hours later. It should have been sat at the login screen,
> > but clearly wasn't.
> > 
> > This time hit Reset rather than Power. When it came back up I got a simple
> > terminal screen telling me the previous desktop session hadn't shutdown
> > properly and advising I switch to another terminal and run <loginctl
> > unlock- sessions>. That seems to have worked OK.
> > 
> > Does anyone know if this odd behaviour stems from me using Suspend?
> > Haven't
> > dared since, it's either on or shutdown now!
> 
> I doubt that it's a suspend problem.  I think that if suspend goes
> wrong, it just won't wake up.  Suspend is usually OK though.
> 
> I would guess at a intermittent hardware error or lack of disk space.
> It could be overheating (are the fans working?) or a disk error.  force
> a Fsck it agian, and check the SMART status info.
> 
> Disk space?  use df -h to see if there's enough space on each partition.
> 
> 
> Is it overheating due to clogging up with dust, or is there a problem
> with the graphics card?
> 
> Anyway, good luck!
> 
> Steve
> 
> 
> 
> _______________________________________________
> main at lists.alug.org.uk
> http://www.alug.org.uk/
> https://lists.alug.org.uk/mailman/listinfo/main
> Unsubscribe?  See message headers or the web site above!





More information about the main mailing list